Back to overview

We are currently experiencing delays in account balance updates.

May 20, 2026 at 8:50am UTC
Affected services
NoFrixion Portal
NoFrixion MoneyMoov API
business.nofrixion.com
NoFrixion Sandbox Portal
NoFrixion Sandbox MoneyMoov API

Resolved
May 20, 2026 at 2:06pm UTC

We have identified the root cause and applied a fix, Payment Operations have resumed to their normal function.

Updated
May 20, 2026 at 1:17pm UTC

Banking Circle our banking partner has observed a significant improvement, with the majority of previously affected banks now back online. Based on the current status, this external incident is considered resolved.

Created
May 20, 2026 at 8:50am UTC

We have identified the root cause and applied a fix, Payment Operations have resumed to their normal function.